npm 更新模块

说明

有时候在写nmp工程的时候,想要更新模块到最新的版本,还是比较麻烦的,这里简要的记录一下过程。

安装

安装 npm-check-updates 模块,官方地址:点击这里

npm install -g npm-check-updates

更新

PS D:\Projects\Web\uniapp-logistics> ncu  # 查看当前可以更新的模块
Checking D:\Projects\Web\uniapp-logistics\package.json
[====================] 29/29 100%

 flyio                      ^0.6.2  →  ^0.6.14
 regenerator-runtime       ^0.12.1  →  ^0.13.3
 vuex                       ^3.0.1  →   ^3.1.1
 @vue/cli-plugin-babel       3.5.1  →   3.11.0
 babel-plugin-import       ^1.11.0  →  ^1.12.2
 miniprogram-api-typings  ^2.8.0-2  →   ^2.8.3

Run ncu -u to upgrade package.json

#####################################################################
PS D:\Projects\Web\uniapp-logistics> ncu -u # 更新package.json中版本
Upgrading D:\Projects\Web\uniapp-logistics\package.json
[====================] 29/29 100%

 flyio                      ^0.6.2  →  ^0.6.14
 regenerator-runtime       ^0.12.1  →  ^0.13.3
 vuex                       ^3.0.1  →   ^3.1.1
 @vue/cli-plugin-babel       3.5.1  →   3.11.0
 babel-plugin-import       ^1.11.0  →  ^1.12.2
 miniprogram-api-typings  ^2.8.0-2  →   ^2.8.3

Run npm install to install new versions.

#####################################################################
PS D:\Projects\Web\uniapp-logistics> npm install # 更新模块版本

备注

npm update只能按照package.json中标注的版本号进行更新,升级后不会修改package.json中的版本号,需要自己手动修改,比较麻烦。

npm-check-updates 升级插件升级后会自动修改package.json里的版本号,简单方便。

点赞